$re = '/\[[^][]+\]\h+=>\h+STRING:\h+"(\w+(?:-\w+)*)"/';
$str = '[TIMETRA-VRTR-MIB::vRtrIfName.22.178] => STRING: "interface900" ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);