const regex = /\{(?!0\})|(?<!\{0)\}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{(?!0\\})|(?<!\\{0)\\}', 'gm')
const str = `AbC{de{0} x{1}}{`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);