using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href=?[?:^""](.*?)([^""]+)*.";
string input = @"Array
(
[0] => <div class=""genel"">
<div>
<ul class=""table-of-contents"">
<li data-part-id=""12"">
<a href=""/sayfa2"" class=""on-navigate-part"">
sayfa1
</a>
</li>
<li data-part-id=""23"">
<a href=""/BarisYILMAZ"" class=""on-navigate-part"">
sayfa2
</a>
</li>
<li data-part-id=""34"">
<a href=""/sayfaZ^''^'^'^'^'^'^'^'^'^+^%%&'^+%^/^&%/%&/%&/"" class=""on-navigate-part"">
sayfa3
</a>
</li>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}