#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\"\"\"(.*?)\"\"\"|'''(.*?)'''|"(.*?)"|'(.*?)'"
Local $sString = "#%%sql" & @CRLF & _
""double quoted string"" & @CRLF & _
"" & @CRLF & _
"q = """" & @CRLF & _
"select" & @CRLF & _
"name, breed, sum(weight) over (partition by breed order by name) as running_total_weight" & @CRLF & _
"from cats" & @CRLF & _
"order by breed, name" & @CRLF & _
""""" & @CRLF & _
"" & @CRLF & _
"'single quoted string'" & @CRLF & _
"foo" & @CRLF & _
"bar" & @CRLF & _
""double quoted string"" & @CRLF & _
"xyz" & @CRLF & _
"'''" & @CRLF & _
"single" & @CRLF & _
"quoted" & @CRLF & _
"multiline" & @CRLF & _
"text" & @CRLF & _
"'''" & @CRLF & _
"end" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")