use strict;
my $str = '#%%sql
"double quoted string"
q = """
select
name, breed, sum(weight) over (partition by breed order by name) as running_total_weight
from cats
order by breed, name
"""
\'single quoted string\'
foo
bar
"double quoted string"
xyz
\'\'\'
single
quoted
multiline
text
\'\'\'
end
';
my $regex = qr/\"\"\"(.*?)\"\"\"|'''(.*?)'''|"(.*?)"|'(.*?)'/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}