# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d(?!\d{0,2}$|\d{13}$)/*/gm;t' <<< "7108898787654351"