use strict;
my $str = '7108898787654351';
my $regex = qr/\d(?!\d{0,2}$|\d{13}$)/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";