$re = '~\b(?:[^.?!]|https?://[^<>\s"\']++)*?sentence(?:[^.?!]|https?://[^<>\s"\']++)*~mu';
$str = 'I don\'t want this piece! This is the <a href=\'https://example.com/my-sentence\'>sentence</a> I want. In don\'t want this piece either';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);