#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])(?<!172\.(16|17|18|19|20|21|22|23|24|25|26|27|28|29|30|31))(?<!127)(?<!^10)(?<!^0)\.([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])(?<!192\.168)(?<!172\.(16|17|18|19|20|21|22|23|24|25|26|27|28|29|30|31))\.([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])(?<!\.255$)$"
Local $sString = "# Invalid IPs:" & @CRLF & _
"999.999.999.999." & @CRLF & _
"108.0.0.01" & @CRLF & _
"0.1.2.3" & @CRLF & _
"00.0000.00.00" & @CRLF & _
"192.168.l.1" & @CRLF & _
"912.456.123.123" & @CRLF & _
".3.3.3.0" & @CRLF & _
"192.168.o.0" & @CRLF & _
"" & @CRLF & _
"# Local IPs:" & @CRLF & _
"172.16.0.9" & @CRLF & _
"172.16.4.1" & @CRLF & _
"172.17.1.1" & @CRLF & _
"127.0.0.2" & @CRLF & _
"10.0.1.5" & @CRLF & _
"10.0.0.1" & @CRLF & _
"10.155.155.155" & @CRLF & _
"10.255.255.254" & @CRLF & _
"172.16.0.4" & @CRLF & _
"172.16.0.1" & @CRLF & _
"172.17.1.1" & @CRLF & _
"172.31.254.254" & @CRLF & _
"192.168.1.2" & @CRLF & _
"192.168.254.0" & @CRLF & _
"169.254.2.2" & @CRLF & _
"" & @CRLF & _
"# Broadcast IPs:" & @CRLF & _
"60.123.247.255" & @CRLF & _
"196.168.255.255" & @CRLF & _
"10.255.255.255" & @CRLF & _
"192.168.255.255" & @CRLF & _
"" & @CRLF & _
"# Public IPs:" & @CRLF & _
"8.8.8.8" & @CRLF & _
"8.8.4.4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")