using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\s*?(?=[a-z0-9-]*[A-Z])(.+)\.(?:i|I)*\s*?\}";
string input = @" FIND {N-CODREM.i} wher
FIND {N-CODRE99.i} wher
FIND { N-CODREM.i } wher
FIND { N-CODREM.I } wher
e {n-codrem.i}.motcle = ""VTE""
e {n-codre99.i}.motcle = ""VTE""
e {n-coDRe99.i}.motcle = ""VTE""
e {n-coDRem.i}.motcle = ""VTE""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}