const regex = /["'`][^"'`]*(?!\\)["'`](*SKIP)(*F) # Make sure we're not matching inside of quotes, double quotes or backticks
|(?m-s:\s*(?:\-{2}|\#)[^\n]*$) # Single line comment
|(?:
\/\*.*?\*\/ # Multi-line comment
(?(?=(?m-s:[\t ]+$)) # Get trailing whitespace if any exists and only if it's the rest of the line
[\t ]+
)
)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('["\'`][^"\'`]*(?!\\\\)["\'`](*SKIP)(*F) # Make sure we\'re not matching inside of quotes, double quotes or backticks
|(?m-s:\\s*(?:\\-{2}|\\#)[^\\n]*$) # Single line comment
|(?:
\\\/\\*.*?\\*\\\/ # Multi-line comment
(?(?=(?m-s:[\\t ]+$)) # Get trailing whitespace if any exists and only if it\'s the rest of the line
[\\t ]+
)
)', 'gs')
const str = `SELECT \`#comment inside string\`;`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);