using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\/\*).+$";
string input = @"Hello NO MATCH
123 NO MATCH
/* HELLo MATCH
/*4534534 MATCH
fsdggg(((*/*";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}