import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\p{L}:]|.[^\\p{L}0-9:\\-_]|[^\\p{L}0-9]$";
final String string = "wdadù\n"
+ "-wdadw\n"
+ "_wdwdawd\n"
+ "23\n"
+ "_33454\n"
+ ".2435\n"
+ "now how\n"
+ "dww\n"
+ "test-now\n"
+ "àwdàawd\n"
+ "wad-àùùdw\n"
+ "test_ok";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}