Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^[^\p{L}:]|.[^\p{L}0-9:\-_]|[^\p{L}0-9]$
/
u
Input 1
1
New
wdadù -wdadw _wdwdawd 23 _33454 .2435 now how dww test-now àwdàawd wad-àùùdw test_ok