$re = '/<span style=(?:\\\\){0,2}"--en-type:(?:\s)??tag;--en-tagId:(?:\s)?([^\/\\\\;]+)(?:;)?(?:\\\\){0,2}">([^<>]+)<\/span>/';
$str = '<!DOCTYPE en-note SYSTEM "http://xml.evernote.com/pub/enml2.dtd"><en-note><p><span style="--en-type:tag;--en-tagId:17436cb0-7873-4317-8453-623e7f3a5dd1;">#234234<>&</span> <span style="--en-type:tag;--en-tagId:ed628b06-297b-4411-9266-3e5fa64f4f5c;">#21423<>14n</span> <span style="--en-type:tag;--en-tagId:27f5d787-9e2a-4d66-9c6e-1f938aa60834;">#2423432</span> </p></en-note>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);