const regex = /(?<=\.)(.*?)(?=\.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\.)(.*?)(?=\\.)', 'gm')
const str = `configurations.ft_alfa.parentConfig=oma
configurations.ft_bpmlz.parentConfig=oma
configurations.ft_cmp.parentConfig=oma
configurations.ft_coda.parentConfig=oma
configurations.ft_fom.parentConfig=oma
configurations.ft_judocs.parentConfig=oma
configurations.ft_life.parentConfig=oma
configurations.ft_nsf.parentConfig=oma
configurations.ft_ods.parentConfig=oma
configurations.ft_psbohra.parentConfig=oma
configurations.ft_rens.parentConfig=oma
configurations.ft_rosy.parentConfig=oma
configurations.ft_sblp.parentConfig=oma
configurations.ft_sbw.parentConfig=oma
configurations.ft_vzb.parentConfig=oma
configurations.ft_enut.parentConfig=oma
configurations.ft_exut.parentConfig=oma`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}