#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?! )(?=.*?[a-z])(?=.*?[A-Z])(?=.*?\d)(?=.*?[[:punct:]])^[ -~]{8,255}(?<!\s)$"
Local $sString = "Should pass:" & @CRLF & _
"aA12345678." & @CRLF & _
"" & @CRLF & _
"Should fail:" & @CRLF & _
"" & @CRLF & _
"No punct:" & @CRLF & _
"aA123456" & @CRLF & _
"" & @CRLF & _
"No lower:" & @CRLF & _
"A123456." & @CRLF & _
"" & @CRLF & _
"No upper:" & @CRLF & _
"a123456." & @CRLF & _
"" & @CRLF & _
"Too short:" & @CRLF & _
"aA1." & @CRLF & _
"" & @CRLF & _
"Too long:" & @CRLF & _
"aA01234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789." & @CRLF & _
"" & @CRLF & _
"Starts with a space:" & @CRLF & _
" aA12345678." & @CRLF & _
"" & @CRLF & _
"Ends with a space:" & @CRLF & _
"aA12345678. "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")