use strict;
my $str = 'Should pass:
aA12345678.
Should fail:
No punct:
aA123456
No lower:
A123456.
No upper:
a123456.
Too short:
aA1.
Too long:
aA01234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789.
Starts with a space:
aA12345678.
Ends with a space:
aA12345678. ';
my $regex = qr/^(?! )(?=.*?[a-z])(?=.*?[A-Z])(?=.*?\d)(?=.*?[[:punct:]])^[ -~]{8,255}(?<!\s)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}