import re
regex = re.compile(r"^(?! )(?=.*?[a-z])(?=.*?[A-Z])(?=.*?\d)(?=.*?[[:punct:]])^[ -~]{8,255}(?<!\s)$", flags=re.MULTILINE)
test_str = ("Should pass:\n"
"aA12345678.\n\n"
"Should fail:\n\n"
"No punct:\n"
"aA123456\n\n"
"No lower:\n"
"A123456.\n\n"
"No upper:\n"
"a123456.\n\n"
"Too short:\n"
"aA1.\n\n"
"Too long:\n"
"aA01234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789.\n\n"
"Starts with a space:\n"
" aA12345678.\n\n"
"Ends with a space:\n"
"aA12345678. ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")