#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^`(另类|基础|应用) .{1,10}` (从(Mongo|MDA|CSR|东财|SnP|Google Sheet)导入|计算|(DEV|PROD)导出到(PG|Arango|ES|MDA)|导出到Google Sheet): ([^ ]+\.[^ ]+)(, [^ ]+\.[^ ]+)*$"
Local $sString = "`另类 排污许可` 从Google Sheet导入: ref.ref_exceed_pollutant_type" & @CRLF & _
"`另类 SAMR` 从Google Sheet导入: pds.source_samr_punishment_manual_reviewed" & @CRLF & _
"`另类 SAMR` 计算: pds.source_samr_punishment, pds.source_samr_punishment_to_review" & @CRLF & _
"`另类 SAMR` DEV导出到PG: ads.esg_alt_penalty_samr_all_prov_stats" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")