use strict;
my $str = '/*
Copyright © 2019 Apple Inc. All rights reserved.
a sdf ja;sdfj
asdfijase
*/
/*
<samplecode>
<abstract>
PositionPlayerTests
</abstract>
</samplecode>
*/
this
this\\
asdas
/*
Copyright © 2020 Apple Inc. All rights reserved.
See Source/LICENSE/LICENSE.txt for details
*/
asdf
asdf
ase
asdsf
';
my $regex = qr//\*.*Copyright.*\n \*/\n/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}