// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Cre.*?\.t\d\.\d").unwrap();
let string = "[b'\\t\\t\\t\\t\\t\\t\\t\\t<td><a href=info.php?id=Cre35.g759247.t1.1+ target=\"_blank\">Cre35.g759247.t1.1 </a></td>']
[b'\\t\\t\\t\\t\\t\\t\\t\\t<td><a href=info.php?id=Cre17.g739850.t1.2 target=\"_blank\">Cre17.g739850.t1.2</a></td>']
[b'\\t\\t\\t\\t\\t\\t\\t\\t<td><a href=info.php?id=Cre17.g737200.t1.2 target=\"_blank\">Cre17.g737200.t1.2</a></td>']";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}