const regex = /foo\/([^\s?]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('foo\\\/([^\\s?]*)', 'gm')
const str = `https://test.com/foo/bar
https://test.com/foo/bar?param1=test
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}