import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?:div|i)(?:.*?(?:class|data-id)=\"([^\"]+)\")?(?:.*?(?:class|data-id)=\"([^\"]+)\")?[^>]*>";
final String string = "<!-- I want to: $matches[1] == test_class | $matches[2] == null -->\n"
+ "<div class=\"test_class\"> \n\n"
+ "<!-- I want to: $matches[1] == test_class | $matches[2] == 1 -->\n"
+ "<div class=\"test_class\" data-id=\"1\"> \n\n"
+ "<!-- I want to: $matches[1] == test_class | $matches[2] == 1 -->\n"
+ "<div id=\"test_id\" class=\"test_class\" data-id=\"1\">\n\n"
+ "<!-- I want to: $matches[1] == test_class test_class2 | $matches[2] == 1 -->\n"
+ "<div class=\"test_class test_class2\" id=\"test_id\" data-id=\"1\">\n\n"
+ "<!-- I want to: $matches[1] == 1 | $matches[2] == test_class test_class2 -->\n"
+ "<div data-id=\"1\" class=\"test_class test_class2\" id=\"test_id\" >\n\n"
+ "<!-- I want to: $matches[1] == 1 | $matches[2] == test_class test_class2 -->\n"
+ "<div id=\"test_id\" data-id=\"1\" class=\"test_class test_class2\">\n\n"
+ "<!-- I want to: $matches[1] == test_class | $matches[2] == 1 -->\n"
+ "<div class=\"test_class\" id=\"test_id\" data-id=\"1\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}