using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(public|protected|private)|(abstract|static)|(final)|(volatile)|(synchronized)|(native)|(strictfp)";
string substitution = @"$1$2$3$4$5$6$7";
string input = @" static public void main(String[] args)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}