#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^///\s*(?:<summary>)?|</summary>)(*SKIP)(*F)|(?:(?!</?summary>|^///(?!/)\s*).)+"
Local $sString = "/// <summary> This is a single-line XML comment. </summary> " & @CRLF & _
"" & @CRLF & _
"/// <summary> This is a multi-line XML comment." & @CRLF & _
"/// These are additional lines with more text." & @CRLF & _
"/// Some more of these text. </summary>" & @CRLF & _
"" & @CRLF & _
"/// <summary> This is another XML text summary with a different" & @CRLF & _
"/// format." & @CRLF & _
"/// </summary>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")