re = /(?:^\/\/\/\s*(?:<summary>)?|<\/summary>)(*SKIP)(*F)|(?:(?!<\/?summary>|^\/\/\/(?!\/)\s*).)+/m
str = '/// <summary> This is a single-line XML comment. </summary>
/// <summary> This is a multi-line XML comment.
/// These are additional lines with more text.
/// Some more of these text. </summary>
/// <summary> This is another XML text summary with a different
/// format.
/// </summary>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end