re = /<\s*span[^>]*>(.*?)<\s*\/\s*span>/m
str = ' <div class="col-9 ml-auto text-right p-0">
<span id="allPopulation" class=" allPopulation number-lg">32.519</span>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end