use strict;
my $str = 'giới thiệu cho tôi về công nghệ xử lý ngôn ngữ tự nhiên?
bạn có thể giới thiệu cho tôi về cách xử lý ngôn ngữ tự nhiên được không.
bạn có thể giới thiệu giú tôi về công nghệ xử lý ngôn ngữ tự nhiên được không.
bạn có thể giúp tôi hiểu về công nghệ ngôn ngữ tự nhiên được không.
công nghệ xử lý ngôn ngữ tự nhiên được như thế nào bạn nhỉ.
bạn có thể giúp tôi hiểu về ngôn ngữ tự nhiên được không.
tôi có thể hiểu về công nghệ ngôn ngữ tự nhiên thế nào bạn nhỉ?
';
my $regex = qr`(giới thiệu|hiểu).*(công nghệ).*(ngôn ngữ tự nhiên)`p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}