$re = '/\(([^()]*)\)/m';
$str = 'I expect five hundred dollars ($500).
I expect.. :( five hundred dollars ($500).';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);