import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\*\\*[\\s\\S]*?\\*\\/";
final String string = "\n\n"
+ "class CategoryController extends Controller\n"
+ "{\n"
+ " /**\n"
+ " * Display a listing of the resource.\n"
+ " *\n"
+ " * @return \\Illuminate\\Http\\Response\n"
+ " */\n"
+ " public function index()\n"
+ " {\n"
+ " //\n"
+ " }\n\n"
+ " /**\n"
+ " * Show the form for creating a new resource.\n"
+ " *\n"
+ " * @return \\Illuminate\\Http\\Response\n"
+ " */\n"
+ " public function create()";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}