use strict;
my $str = 'SQL: [126] INSERT INTO `tbl_ip_data` (`ip_start`, `ip_end`, `region_id`, `country_id`, `create_at`)
VALUES (:v0d, :v1d, :v2d, :v3d, :v4d) Sent SQL: [163] INSERT INTO `tbl_ip_data` (`ip_start`, `ip_end`, `region_id`, `country_id`, `create_at`)
VALUES (\'1900145563\', \'1900145563\', \'440118\', \'CN\', \'2022-04-15 21:46:42\') Params: 5 Key: Name: [4] :v0d paramno=-1 name=[4] ":v0d" is_param=1 param_type=2 Key: Name: [4] :v1d paramno=-1 name=[4] ":v1d" is_param=1 param_type=2 Key: Name: [4] :v2d paramno=-1 name=[4] ":v2d" is_param=1 param_type=2 Key: Name: [4] :v3d paramno=-1 name=[4] ":v3d" is_param=1 param_type=2 Key: Name: [4] :v4d paramno=-1 name=[4] ":v4d" is_param=1 param_type=2 [] []';
my $regex = qr/SQL: \[\d+\] (?<sql>.*) Sent SQL: \[\d+\] (?<send_sql>.*) Params:/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}