use strict;
my $str = 'Hello World. Hello World.Hello World.Hello World';
my $regex = qr/\.(?=[A-Z])/mp;
my $subst = '\\.\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";