import Foundation
let pattern = #"\.(?=[A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Hello World. Hello World.Hello World.Hello World"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\.\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)