# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^\d{1,2})(th|rd|nd)(\s)(\w+)(\s)(\d{4})/\1 \4 \6/gm;t' <<< "12/jan/2023"