const regex = new RegExp('(^\\d{1,2})(th|rd|nd)(\\s)(\\w+)(\\s)(\\d{4})', 'gm')
const str = `12/jan/2023`;
const subst = `\1 \4 \6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);