use strict;
my $str = '12/jan/2023';
my $regex = qr`(^\d{1,2})(th|rd|nd)(\s)(\w+)(\s)(\d{4})`mp;
my $subst = '\\1 \\4 \\6';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";