using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/)?(www\.)?[-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,6}\b([-a-zA-Z0-9@:%_\+.~#?&//=]*)";
string input = @"http://foo.com/blah_blah
http://foo.com/blah_blah/
http://www.example.com/wpstyle/?p=364
https://www.example.com/foo/?bar=baz&inga=42&quux
http://userid:password@example.com:8080
http://foo.com/blah_(wikipedia)#cite-1
www.google.com
http://../
http:// shouldfail.com
http://224.1.1.1
http://142.42.1.1:8080/
ftp://foo.bar/baz
http://1337.net
http://foo.bar/?q=Test%20URL-encoded%20stuff
http://code.google.com/events/#&product=browser";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}