import Foundation
let pattern = ##"(https?:\/\/)?(www\.)?[-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,6}\b([-a-zA-Z0-9@:%_\+.~#?&//=]*)"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
http://foo.com/blah_blah
http://foo.com/blah_blah/
http://www.example.com/wpstyle/?p=364
https://www.example.com/foo/?bar=baz&inga=42&quux
http://userid:password@example.com:8080
http://foo.com/blah_(wikipedia)#cite-1
www.google.com
http://../
http:// shouldfail.com
http://224.1.1.1
http://142.42.1.1:8080/
ftp://foo.bar/baz
http://1337.net
http://foo.bar/?q=Test%20URL-encoded%20stuff
http://code.google.com/events/#&product=browser
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)