package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9]*$`)
var str = `hello90
what
how are you?
hi5
8ask`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}