#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z0-9._%-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,6})*$"
Local $sString = "email@example.com" & @CRLF & _
"firstname.lastname@example.com" & @CRLF & _
"email@subdomain.example.com" & @CRLF & _
"1234567890@example.com" & @CRLF & _
"email@example-one.com" & @CRLF & _
"firstname-lastname@example.com" & @CRLF & _
"jpemail@example.co.jp" & @CRLF & _
""email"@example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")