// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-zA-Z0-9._%-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,6})*$").unwrap();
let string = "email@example.com
firstname.lastname@example.com
email@subdomain.example.com
1234567890@example.com
email@example-one.com
firstname-lastname@example.com
jpemail@example.co.jp
\"email\"@example.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}