$re = '/<%([-=]):\s*([^|]*?)\s*\|\s*(\w+)(?::([^%]+?))?\s*%>/m';
$str = '<%=: price | moneyFormat:currency %>
<%=: price | moneyFormat:currency, option2 %>
# Why we need the second regex:
<%=: price | moneyFormat %>
';
$subst = "<%\1 filters.\3(\2, \4) %>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;