#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[-+ ]?[178]?[а-яa-z ]*\d[а-яa-z ]*\d[а-яa-z ]*\d[а-яa-z ]*\d[а-яa-z ]*\d[а-яa-z ]*\d[а-яa-z ]*\d[а-яa-z]*\d[а-яa-z ]*\d[а-яa-z ]*\d.$"
Local $sString = "40 : Fubag - DS 35000 DAES, 920 м/час наработки. Цена договорная. Возможен обмен на а/м "Нива"-4313. Обращаться по номеру: восемь девятьсот тринадцать 8851696 " & @CRLF & _
"" & @CRLF & _
"41 : Пеллеты от производителя(Ель-пихта), фасовка мешки 43кг d-1 находимся в районе д. Старцево/" & @CRLF & _
"Дополнительный номер: 4-800-323 " & @CRLF & _
"" & @CRLF & _
"42 : Предлагаем укорененные черенки крупнолистной гортензии в ассортименте./" & @CRLF & _
"Качественные саженцы с закрытой корневой системой в горшке Р9. Интересные сорта, подтвержденная сортность. Возможна курьерская доставка по Тольятти, а так же доставка по всей России через транспортные компании или почтой/" & @CRLF & _
"Подробнее на сайте сады-эдема точка рф " & @CRLF & _
"" & @CRLF & _
"43 : ❗️СРОЧНО продам дом❗️/" & @CRLF & _
"/" & @CRLF & _
"На территории, ограждённой железной оградой, находится дом площадью 45,8 и кирпичная времянка - 42,5. Так же беседка 4*1. Дворик уложен плиткой с небольшим участком земли./" & @CRLF & _
"Произведен косметический ремонт. Установлены пластиковые окна. /" & @CRLF & _
"Санузел находится как на улице, так и в доме. /" & @CRLF & _
"/" & @CRLF & _
"❗️ТОРГ❗️реальному покупателю и мебель по договоренности/" & @CRLF & _
"/" & @CRLF & _
"Все вопросы ТОЛЬКО по телефону +7 961 364-77-06 Таисья " & @CRLF & _
"" & @CRLF & _
"44 : Продается комплект оригинальных новых фар на Тайоту Камри 1042 года, тел:+79454655924 " & @CRLF & _
"" & @CRLF & _
"45 : ПPОФЕССИОНAЛЬНАЯ СОЛHЦЕЗAЩИТA/" & @CRLF & _
" Собственнoе пpoизвoдcтвo жaлюзи и рулонных штoр/" & @CRLF & _
" Реaльно НИЗKИE цeны, oгромный выбoр цветoв и фактур ткaни./" & @CRLF & _
" /" & @CRLF & _
"Рулoнныe каccетныe штopы УHИ 3, УHИ 5./" & @CRLF & _
" Изделие крeпится нa рaму окнa , оcтaвляя оконноe пpоcтpaнcтво свoбодным.Элeгантный кopоб скрывает тканевый рулон и механизмы, а направляющие защищают от боковых просветов./" & @CRLF & _
" МОНТАЖ БЕЗ СВЕРЛЕНИЯ РАМЫ (на скотч)/" & @CRLF & _
" /" & @CRLF & _
"Замеры с образцами материалов-БЕСПЛАТНО, Звоните, предварительно рассчитаем стоимость заказа по телефону. /" & @CRLF & _
"/" & @CRLF & _
"BEPТИКАЛЬНЫE /" & @CRLF & _
"ГОPИЗОНTАЛЬHЫЕ/" & @CRLF & _
"РУЛОНHЫЕ/" & @CRLF & _
"ЗЕБРA/" & @CRLF & _
"ДОСТАВКА УСТАНОВКА БЕСПЛАТНО /" & @CRLF & _
"ПО ВСЕЙ ЧР./" & @CRLF & _
"8к9о5д9и8и9и2и0а1а1и0 " & @CRLF & _
"" & @CRLF & _
"46 : Продам резину летнюю в отличном состоянии Pirelli Cinturato P1.Звонить на 8 930 546 4594 " & @CRLF & _
"" & @CRLF & _
"47 : Ищем мастера маникюра.График сменный .Оплата 20/20./" & @CRLF & _
"509-03-60 " & @CRLF & _
"" & @CRLF & _
"48 : трёхкомнатная 89 квартира 05 для 537 русской 44 семьи,92 цокольный этаж(высокий) санузел раздельный . Людмила Николаевна. " & @CRLF & _
"" & @CRLF & _
"49 : 89068536571 Костя " & @CRLF & _
"" & @CRLF & _
"50 : продам 24000 звонить по номеру +79257500273. " & @CRLF & _
"" & @CRLF & _
"51 : Два котика ,окраса вискас /" & @CRLF & _
"Котята тяжеловесы от крупных,привитых родителей./" & @CRLF & _
"Родились 16.08,котята кушают сами ,корм сухой,мяско ,молочко.лоток знают без погрешностей ./" & @CRLF & _
"Очень игривые малыши ,контактные .у котиков разные характеры)/" & @CRLF & _
"/" & @CRLF & _
"Звонить на этот номер- девятьсоттринадцать,стосемдесят,Сороктри,девяносточетыре,)лучше писать тут в любое время)/" & @CRLF & _
"Приезжайте смотреть какие они замечательные)) " & @CRLF & _
"" & @CRLF & _
"52 : Спиро-68 руб.Спиротек ультра. Цена-14 руб./шт. Есть респираторы зм 8661,9551,8606, полумаска 5М 7401, маска 5М 3800, фильтра угольные 3049,3046,перчатки рабочие обливные маслобензостойкие.пишите,звоните,узнавайте. " & @CRLF & _
"" & @CRLF & _
"53 : Спортивные покрытия. От 190 рублейПроизводитель! Бесплатная доставка! Скачайте прайс лист и выберите то, что нужноУзнать большеtopmat36.ruЯндекс.Директ/" & @CRLF & _
"/" & @CRLF & _
"/" & @CRLF & _
"/" & @CRLF & _
"2 / 7/" & @CRLF & _
"/" & @CRLF & _
"Комбинезон titan centurion nxg super + /" & @CRLF & _
"/" & @CRLF & _
"Koмбeз для пpиcедaния TIТАN SUРЕR Cеnturion Suit NХG Suреr+ R/S pазмер 66 на катeгopию 200-205кг. cостояние отличноe, без дефeктoв. (узкaя/cpедняя пocтaнoвкa нoг) цeнa нoвoгo 24000, моя цeнa 1500рублeй./" & @CRLF & _
"/" & @CRLF & _
"TIТAN SUРER Cеnturiоn (цент, центуриoн) - сaмый пoпулярный и самый жecткий из комбинезонов pазрешенных в IРF./" & @CRLF & _
"/" & @CRLF & _
"Жесткая ткань нового поколения, практически не растягивается в процессе использования. Дополнительную прочность комбезу придают укрепляющие двойные и тройные швы, расположенные в местах наибольшей нагрузки. Материал NХG Suреr+ обеспечивает комбинезону долговечность./" & @CRLF & _
"/" & @CRLF & _
"Жесткая ткань NХG Suреr+, уникальная конструкция, длинные лямки, широкий вырез, прочные двойные и тройные швы, - вот основа этого костюма. При экстремальном размере и сильной намотке бинтов можно вытянуть из этого костюма до 200 кг прибавки к результату, обычно же 10-80 кг./" & @CRLF & _
"/" & @CRLF & _
"Несомненным плюсом данного комбеза является его универсальность - можно использовать в становой тяге. В тяге он дает хороший срыв, но дотягивать придется самому. Атлетам, которым тяжело дается именно отрыв, даст отличную возможность тянуть большие веса./" & @CRLF & _
"/" & @CRLF & _
"Комбез для приседания ТIТАN SUРЕR Сеnturiоn Suit NХG Suреr+ позволяет спортсмену максимально реализовать свой потенциал в приседаниях, а широкие лямки сделают движение более комфортным. " & @CRLF & _
"" & @CRLF & _
"54 : Продам хорошую 4-х комнатную квартиру в сталинке, пластиковые окна во всей квартире, квартира под ремонт и он уже начат и идёт по тихоньку, поменяны радиатор и трубы отопления в зале, поменяна электро проводка в зале, наклеены обои в зале, уложен ламинат, /" & @CRLF & _
"вопросы задавайте по звонку или встрече, всё расскажу и покажу! Звонить на номер 8девять219ноль26747, Агенствам не беспокоить!!! " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")