use strict;
my $str = 'http://static.test/aboroni/media//polo-shirts//
';
my $regex = qr~([^:])(/{2,})~p;
my $subst = '$1/';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";