import re
regex = re.compile(r"([^:])(/{2,})")
test_str = ("http://static.test/aboroni/media//polo-shirts//\n\n")
subst = "$1/"
result = regex.sub(subst, test_str)
if result:
print(result)