use strict;
my $str = 'table9 dolv5e #10n #dec10 #nov8e 23 hello';
my $regex = qr/(#\S+)|\d+/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";