# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+(?=\[))\[([^\(\[\{\}\]\)]+)\]//g;t' <<< "//Valid match
12[red,green],13[xs,xl,xxl]
number[anythingBut ()[]{},anythingBut ()[]{}](,number[anythingBut ()[]{},anythingBut ()[]{}]) or nothing
//Not valid match
12[red,green],13[xs,xl,xxl 9974-?ds12[dfgd,dfgd]]"