$re = '/^(?!00)(?!0+(?:[.,]\d{1,2})?$)\d{1,4}(?:[.,]\d{1,2})?$/m';
$str = '01
-> valid
00
-> not valid
0
-> not valid
1
-> valid
001
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);