import re
regex = re.compile(r"\[([^]]+)\]([^[]+)\[\/\1\]", flags=re.MULTILINE)
test_str = ("[highlight][b]xxxxxx[/b][/highlight]\n")
subst = "\\2"
result = regex.sub(subst, test_str)
if result:
print(result)